wiki:CompileMan-DB-2.6.5

Man-DB-2.6.5

  • Can be Compiled or Not? No
  • Package Download Link: http://download.savannah.gnu.org/releases/man-db/man-db-2.6.5.tar.xz
  • Compile Script:
    #!/bin/bash
    
    export PACKAGE_NAME=man-db-2.6.5
    export NACL_ARCH=x86_64
    export NACL_GLIBC=1
    export NACLPORTS_PREFIX=${REPY_PATH}/usr
    
    source ../naclports/src/build_tools/common.sh
    
    export NACL_SEL_LDR
    export NACL_IRT
    export NACL_SDK_LIB
    export CC=${NACLCC}
    export CXX=${NACLCXX}
    export AR=${NACLAR}
    export RANLIB=${NACLRANLIB}
    export PKG_CONFIG_PATH=${NACLPORTS_LIBDIR}/pkgconfig
    export PKG_CONFIG_LIBDIR=${NACLPORTS_LIBDIR}
    export FREETYPE_CONFIG=${NACLPORTS_PREFIX_BIN}/freetype-config
    export PATH=${NACL_BIN_PATH}:${PATH};
    
    export NETTLE_CFLAGS=${NACLPORTS_PREFIX}/include
    export GMP_CFLAGS=${NACLPORTS_PREFIX}/include
    
    conf_host=${NACL_CROSS_PREFIX}
    
    Banner "Configure man-db-2.6.5"
    ChangeDir "../man-db-2.6.5"
    ./configure\
         --prefix=${NACLPORTS_PREFIX} --enable-shared --host=x86_64-linux
    make clean
    make
    
    
  • Remaining Problem:
    configure: error: Package requirements (libpipeline >= 1.1.0) were not met:
    
    No package 'libpipeline' found
    
    
Last modified 4 years ago Last modified on Sep 24, 2013 11:14:24 PM